Eliminar Cadenas De Consulta De Recursos Estáticos

El código debajo permite eliminar la cadena de caracteres que muestra la versión de los archivos como javascript y css, es algo como /wp-includes/js/jquery/jquery.js?ver=1.4.2.

Problema

Esto puede que ocasione problemas en algunos servidores. Herramientas como Google Speed, YSlow y Pingdom Tools sugieren remover la versión de estos archivos para incrementar la velocidad de carga de nuestro sitio y se debe a que algunos servidores pueden causar problemas cuando tratan de cachear estos recursos.

Solución

function remove_script_version($src) {
    $parts = explode('?', $src);
    return $parts[0];
}
add_filter('script_loader_src', 'remove_script_version', 15, 1);
add_filter('style_loader_src', 'remove_script_version', 15, 1);