HTML5 Shim solo para Internet Explorer

Este código es una función para wordpress que llama el javascript de Google HTML5 shim/shiv que incluye soporte de HTML5 para los usuarios de IE y sólo se carga si se está utilizando Internet Explorer 8 o menor. Solo copia y pega este código en el archivo functions.php de tu tema.

Modernizr ofrece compatibilidad HTML5 y CSS3 y puedes incluir HTML5 Shim como parte de la librería.

// Google HTML5 Shim, solo para IE8 y menor 
function wpfme_IEhtml5_shim () {
    global $is_IE;
    if ($is_IE)
        echo '<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->';
}
add_action('wp_head', 'wpfme_IEhtml5_shim');
Recomendado